Difference between revisions of "OSQA"

From stacky wiki
Jump to: navigation, search
(MathJax)
(Installation)
Line 2: Line 2:
 
Followed the instructions here [http://wiki.osqa.net/display/docs/Installing+OSQA+on+DreamHost]. Seems to work, using the modified (truncated) <code>passenger_wsgi.py</code> file [http://wiki.osqa.net/display/docs/Installing+OSQA+on+DreamHost?focusedCommentId=3047706#comment-3047706].
 
Followed the instructions here [http://wiki.osqa.net/display/docs/Installing+OSQA+on+DreamHost]. Seems to work, using the modified (truncated) <code>passenger_wsgi.py</code> file [http://wiki.osqa.net/display/docs/Installing+OSQA+on+DreamHost?focusedCommentId=3047706#comment-3047706].
  
Email settings: used <code>mail.stacky.net</code>, port 587 (see this thread [http://blog.dreamhosters.com/kbase/index.cgi?area=658]) with a user I created through Dreamhost web panel. Checked "Use TLS".
+
Email settings: used <code>mail.stacky.net</code>, port 587 (see this thread [http://blog.dreamhosters.com/kbase/index.cgi?area=658]) with a user I created through Dreamhost web panel. Checked "Use TLS". This worked (I got a test email), but seems to not work now that I've successfully imported the FTS database.
  
 
==Importing==
 
==Importing==

Revision as of 09:04, 11 May 2011

Installation

Followed the instructions here [1]. Seems to work, using the modified (truncated) passenger_wsgi.py file [2].

Email settings: used mail.stacky.net, port 587 (see this thread [3]) with a user I created through Dreamhost web panel. Checked "Use TLS". This worked (I got a test email), but seems to not work now that I've successfully imported the FTS database.

Importing

went to http://osqa.stacky.net/admin/sximporter, downloaded and selected zipped dump from faketestsite, submitted to get error. Copy of the error log [4]. I think the problem is that there existed a question already. Tried again with new database; worked!

MathJax

Added the line
<script type="text/javascript" src="http://stacky.net/MathJax/MathJax.js?config=MOconfig"></script>
just before </head> in forum/skins/default/templates/base_content.html. That seems to roughly do the trick.

MathML

Compatibility