Difference between revisions of "Xps 15"

From stacky wiki
Jump to: navigation, search
Line 10: Line 10:
 
* created a recovery drive: http://www.dell.com/support/article/us/en/19/sln299044/how-to-create-and-use-the-dell-windows-recovery-image?lang=en
 
* created a recovery drive: http://www.dell.com/support/article/us/en/19/sln299044/how-to-create-and-use-the-dell-windows-recovery-image?lang=en
 
* turned on developer mode and enabled windows subsystem for Linux: https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/
 
* turned on developer mode and enabled windows subsystem for Linux: https://www.howtogeek.com/249966/how-to-install-and-use-the-linux-bash-shell-on-windows-10/
 +
 +
*Change SATA Operation so that Ubuntu can see the SSD
 +
**Login into Windows 10, and set up Safe Mode: "Change advanced Startup Options" -> "Restart Now" -> "Troubleshoot" > "Advanced options" > "Startup Settings" > "Restart"
 +
**Boot laptop and press F2 -> BIOS Setup
 +
**System Configuration -> SATA Operation
 +
**Change SATA Operation from "RAID On" to "AHCI"
 +
**Apply and Exit. This will reboot the laptop, and provide several boot options
 +
**Choose "4. Safe Mode"
 +
**"Start" -> "Windows System" -> "Control Panel" -> "Device Manager". Check that the "IDE ATA/ATAPI controller" is "Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller"
 +
**Reboot normally. This should boot into the regular Window 10
 +
**If you reboot and go into the BIOS, SATA Operation should still be AHCI
 +
 +
* Prep drive for Ubuntu install:
 +
** right click on start menu, select command prompt in admin mode
 +
** run <code>diskmgmt.msc</code>
 +
** right click c:, shrink volume ... doesn't work, because it won't let me shrink by more than half.
 +
* Install Ubuntu:

Revision as of 22:17, 26 October 2017

Following instructions from

Stuff I did:

  • Change SATA Operation so that Ubuntu can see the SSD
    • Login into Windows 10, and set up Safe Mode: "Change advanced Startup Options" -> "Restart Now" -> "Troubleshoot" > "Advanced options" > "Startup Settings" > "Restart"
    • Boot laptop and press F2 -> BIOS Setup
    • System Configuration -> SATA Operation
    • Change SATA Operation from "RAID On" to "AHCI"
    • Apply and Exit. This will reboot the laptop, and provide several boot options
    • Choose "4. Safe Mode"
    • "Start" -> "Windows System" -> "Control Panel" -> "Device Manager". Check that the "IDE ATA/ATAPI controller" is "Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller"
    • Reboot normally. This should boot into the regular Window 10
    • If you reboot and go into the BIOS, SATA Operation should still be AHCI
  • Prep drive for Ubuntu install:
    • right click on start menu, select command prompt in admin mode
    • run diskmgmt.msc
    • right click c:, shrink volume ... doesn't work, because it won't let me shrink by more than half.
  • Install Ubuntu: